On Wed, Aug 9, 2017 at 3:39 PM, Tom Lane <t...@sss.pgh.pa.us> wrote:
> Michael Paquier <michael.paqu...@gmail.com> writes:
>> On Tue, Aug 8, 2017 at 11:33 PM, Tom Lane <t...@sss.pgh.pa.us> wrote:
>>> Michael Paquier <michael.paqu...@gmail.com> writes:
>>>> I got the same thought, wondering as well if get_slot_xmins should be
>>>> renamed check_slot_xmins with the is() tests moved inside it as well.
>>>> Not sure if that's worth the API ugliness though.
>>> Mmm, doesn't seem like that's worth doing, but I'm half tempted to merge
>>> wait_slot_xmins into get_slot_xmins so you can't skip it ...
>> Let's do that please. Merging both was my first feeling when
>> refactoring this test upthread. Should I send a patch?
> Sure, have at it.

And here you go.

Attachment: tap-simplify-repslot.patch
Description: Binary data

Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:

Reply via email to