Another problem with this patch is the search-and-replace substitution
of "SECS_PER_MINUTE" for "60", when in point of fact there are two
different meanings of "60" in this context.  For instance, this
code has no problem:

! int                   Log_RotationAge = 24 * 60;

but this code looks like it has a units error:

! int                   Log_RotationAge = HOURS_PER_DAY * SECS_PER_MINUTE;

You need a "MINS_PER_HOUR" or some such if you don't want people
having to look twice at the code.

BTW, if you actually wanted to improve readability, defining a
SECS_PER_YEAR value and replacing the various occurrences of
"36525 * 864" with it would help.

                        regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 4: Have you searched our list archives?

               http://archives.postgresql.org

Reply via email to