Martijn van Oosterhout <> writes:
> On Fri, Jul 21, 2006 at 01:42:26PM +0200, Peter Eisentraut wrote:
>> I would prefer to drop the PG_ prefixes on PG_TRACE and pg_trace.h.  We
>> know which software we're dealing with.

> I don't know. "trace" is a fairly generic word, how do you know that
> none of the dozen other libraries we include don't already have a
> "trace.h" or a TRACE() macro? On any of our supported platforms?

I concur with Martijn.  We've already regretted using ERROR as a macro
name, let's not make the same mistake with TRACE.  PG_TRACE is good,
and so is pg_trace.h.  (But invoking it as utils/trace.h would be ok.)

                        regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 3: Have you checked our extensive FAQ?


Reply via email to