I couldn't remember if you wanted grammar/spelling nitpicks, so I
included them... sorry for the noise if you didn't want them.
#Improve performance of statistics monitoring, especially
I would s/pg_stat_activity/stats_command_string/, since that's where the
actual change was. Can probably get combined with "Default
stats_command_string to 'on'" as well.
"Add system view pg_prepared_statements to show prepared statements
Add system view pg_cursors to show open cursors (Joachim Wieland)
Both this and pg_prepared_statements are very useful for pooled
Should read "Both of these are very useful..."
"The old behavior is still available by omitting '.'. The new behavior is
substantially more useful since it allows, for example, triggers to
check for data changes with 'if row(new.) is distinct from row(old.*)'."
This isn't really clear... are you saying you can do if row(new*)? Also,
is the lack of * in the new example intentional?
"Allow placeholder (shell) types to be create (Martijn van Oosterhout)"
should be created...
"Remove dead index entries during btree page split (Junji Teramoto)"
Technically should be s/during/before/. Though, this is already listed
before under performance; not sure what the intention with duplicate
"Avoid extra scan of table during VACUUM of index-less table (Greg
Should be 'tables'.
"Add option to allow indexes to be created indexes without blocking
concurrent writes to the table (Greg Stark)"
Drop second 'indexes'.
"Add option to run the entire session in a single transaction (Simon)"
If this is doing what I think it is, it'd be clearer to say "allow
turning autocommit off". We're not actually inforcing that the entire
session be a single transaction, right?
"Rtree has been re implemented using GIST."
Jim Nasby [EMAIL PROTECTED]
EnterpriseDB http://enterprisedb.com 512.569.9461 (cell)
---------------------------(end of broadcast)---------------------------
TIP 2: Don't 'kill -9' the postmaster