Bruce Momjian <[EMAIL PROTECTED]> writes:
> Tom Lane wrote:
>> I'm disinclined to change that, because it would probably break existing
>> client-side code for little gain.

> I think clarity suggests we should make the heading match the feature,
> i.e call it "advisory" rather than "userlock".   We changed the API, I
> don't see why keeping the heading makes sense. 

(a) we changed a *different* part of the API; I don't see how that
licenses us to whack around anything that's marginally related.

(b) we put up that pgfoundry module so that there would be a backward
compatible solution.  Won't be very backward compatible if the locks
look different in pg_locks.

                        regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 1: if posting/reading through Usenet, please send an appropriate
       subscribe-nomail command to [EMAIL PROTECTED] so that your
       message can get through to the mailing list cleanly

Reply via email to