Tom Lane wrote:
> Bruce Momjian <[EMAIL PROTECTED]> writes:
> > Tom Lane wrote:
> >> I'm disinclined to change that, because it would probably break existing
> >> client-side code for little gain.
> > I think clarity suggests we should make the heading match the feature,
> > i.e call it "advisory" rather than "userlock".   We changed the API, I
> > don't see why keeping the heading makes sense. 
> (a) we changed a *different* part of the API; I don't see how that
> licenses us to whack around anything that's marginally related.
> (b) we put up that pgfoundry module so that there would be a backward
> compatible solution.  Won't be very backward compatible if the locks
> look different in pg_locks.

But is anyone going to know what userlocks is in 1-2 years?  We have few
people using /contrib/userlocks, but in the future, I bet we have a lot
more people using advisory locks, and being confused.

  Bruce Momjian   [EMAIL PROTECTED]

  + If your life is a hard drive, Christ can be your backup. +

---------------------------(end of broadcast)---------------------------
TIP 3: Have you checked our extensive FAQ?


Reply via email to