Magnus Hagander writes:
> Now, I still twist my head around the lines:
>       if ((fd = _open_osfhandle((long) h, fileFlags & O_APPEND)) < 0
> ||
>               (fileFlags & (O_TEXT | O_BINARY) && (_setmode(fd,
> fileFlags & (O_TEXT | O_BINARY)) < 0)))
> With the _setmode() call deep in the if statement... I would suggest we
> split that up into a couple of lines to make it more readable - I'm sure
> all compilers will easily optimise it into the same code anyway.
> Reasonable?

I agree it would be clearer if split up.

Without having studied it closely, it might also highlight a bug on failure of 
the second clause -- if the _setmode fails, shouldn't _close be called instead 
of CloseHandle, and -1 returned?  (CloseHandle would still be called on failure 
of the _open_osfhandle, obviously)


---------------------------(end of broadcast)---------------------------
TIP 1: if posting/reading through Usenet, please send an appropriate
       subscribe-nomail command to [EMAIL PROTECTED] so that your
       message can get through to the mailing list cleanly

Reply via email to