Peter Eisentraut <[EMAIL PROTECTED]> writes:
> Just to get an opinion, which is better:
> could not open whatever file "%s": %m
> or just:
> could not open file "%s": %m

> It seems to me that by the time you get to a file error message of this 
> level, the higher-level purpose of the file is pretty irrelevant.  

I like the more verbose variant myself, and would argue that indeed our
message style guidelines mandate it:

        45.3.9. Type of the object

        When citing the name of an object, state what kind of object it is.

        Rationale: Otherwise no one will know what "" refers to.

A seasoned developer might only need the file name to guess what kind of
file it is, but other people could probably use the help.

                        regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 3: Have you checked our extensive FAQ?


Reply via email to