On Aug 3, 2007, at 14:59 , Simon Riggs wrote:

On Fri, 2007-08-03 at 12:38 -0400, Tom Lane wrote:
Alvaro Herrera <[EMAIL PROTECTED]> writes:
Gregory Stark wrote:
Could I suggest renaming log_autovacuum to log_autovacuum_min_duration?

Sure, whatever makes the most sense. In fact min_duration would be more

I'm not sure I believe Greg's argument about needing more autovac
logging parameters, but since this one acts just like
log_min_duration_statement, I concur with renaming it.

makes the most sense in comparison, IMHO.

True, but the log_min_duration_statement is kind of poorly named (as is log_min_error_statement). log_statement is the overall concept, min_duration and min_error further specialize the concept. log_statement_min_duration and log_statement_min_error would have been better, IMO. Question is whether it's better to move forward with consistent naming or improve naming when the chance arises.

Michael Glaesemann
grzm seespotcode net

---------------------------(end of broadcast)---------------------------
TIP 1: if posting/reading through Usenet, please send an appropriate
      subscribe-nomail command to [EMAIL PROTECTED] so that your
      message can get through to the mailing list cleanly

Reply via email to