On 8/15/07, Tom Lane <[EMAIL PROTECTED]> wrote:
> For example, "log_line_prefix" is misnamed under this rule, and ought to
> be "logging_line_prefix".  Similarly, redirect_stderr would become
> "logging_something" --- I'd prefer "logging_start_collector" but could
> live with "logging_collector" (or maybe "logging_use_collector"?)

The consistent prefix idea sounds good; does "logging_enable" jive
with your proposal?

Introduction of the term "collector" might be an overthink, and could
confuse people.  Your average postgres user tweaking his config file
is going to see that and wonder what on earth a "log collector" is.

Whereas it's generally understood that to "log" is to capture output
and make it persistent, and "logging_enable" is clearly a setting that
allows this to take place.

---------------------------(end of broadcast)---------------------------
TIP 6: explain analyze is your friend

Reply via email to