I have just noticed that a column "txn_start" has appeared in
pg_stat_activity since 8.2.  It's a good idea, but who chose the name?
We do not use that abbreviation for "transaction" anywhere else in
Postgres, certainly not in any user-exposed places.

I'm inclined to rename it to "xact_start", which is an abbreviation
that we *do* use in the code, and in some user-visible places, eg,
pg_stat_database has "xact_commit" and "xact_rollback" columns.

Other suggestions?  If we don't change it before 8.3 beta starts,
we'll be stuck with it ...

                        regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 1: if posting/reading through Usenet, please send an appropriate
       subscribe-nomail command to [EMAIL PROTECTED] so that your
       message can get through to the mailing list cleanly

Reply via email to