On Mon, 2007-09-10 at 21:04 -0400, Tom Lane wrote:
> I have just noticed that a column "txn_start" has appeared in
> pg_stat_activity since 8.2.  It's a good idea, but who chose the name?


> I'm inclined to rename it to "xact_start", which is an abbreviation
> that we *do* use in the code, and in some user-visible places, eg,
> pg_stat_database has "xact_commit" and "xact_rollback" columns.

I personally find "xact" to be a less intuitive abbreviation of
"transaction" than "txn", but for the sake of consistency, I agree it is
probably better to use "xact_start".


---------------------------(end of broadcast)---------------------------
TIP 1: if posting/reading through Usenet, please send an appropriate
       subscribe-nomail command to [EMAIL PROTECTED] so that your
       message can get through to the mailing list cleanly

Reply via email to