Andrew Dunstan wrote:

Zdenek Kotala wrote:

Tom Lane wrote:

Gregory Stark <[EMAIL PROTECTED]> writes:

We previously discussed compressing the numeric data type for small values:

We didn't do this for 8.3 but in any case Tom did suggest we ought to reverse the weight and sign/dscale so we could do this sometime without introducing
another incompatibility.

I had forgotten about that, but it does seem like a good idea to do it now.
Any objections?

For in-place upgrade purpose It would be good change also OID for numeric type and preserve current OID for current implementation on updated system.

If we want to get into that game we need a better way of allocating Oids. Right now anything not currently used is liable to be grabbed, so there's a high risk of reuse.

Yes, it will be necessary. Or maybe second way is create only really base types (name, int, bool ...) on bootstrap and others types will be created in standard manner by CREATE TYPE, CREATE OPERATOR ... commands. Or third way is not remove old datatypes and only rename them to e.g. numeric_old1 ...


---------------------------(end of broadcast)---------------------------
TIP 1: if posting/reading through Usenet, please send an appropriate
      subscribe-nomail command to [EMAIL PROTECTED] so that your
      message can get through to the mailing list cleanly

Reply via email to