I found when I removed all comments, it worked fine.  Any ideas?



[mailto:[EMAIL PROTECTED] On Behalf Of Boergesson,
Sent: Thursday, October 18, 2007 9:24 AM
To: pgsql-hackers@postgresql.org
Subject: [HACKERS] upgrade from 8.0.3 to 8.1.10 crash


Hello.  I am trying to upgrade from PostgreSQL 8.0.3 to PostgreSQL
8.1.10.  I'm on WindowsXP and I'm compiling with Visual C++ 6.0.


I have a very simple routine that works fine with the 8.0.3 version:


int easy_connect()


exec sql connect to my_db as my_cnxtn;

printf ("connection results:\n");

printf ("code: %d\n", sqlca.sqlcode);

printf ("state: %s\n", sqlca.sqlstate);

printf ("warn: %s\n", sqlca.sqlwarn);

exec sql begin work;

exec sql commit work;

return 0;



When I use the 8.1.10 version, the connection works ( sqlca.sqlcode is
0, sqlca.sqlstate is 0000 and sqlca.sqlwarn is blank).  But it then
crashes on the "exec sql begin work" line.


I get the following error in a window:


Runtime Error!


Program: C:\testSQL.exe


This application has requested the Runtime to terminate it in an unusual

Please contact the application's support team for more information.


I removed the 8.0.3 version using "remove program" from the control
panel.  I then went and removed my C:\Program Files\PostgreSQL\8.0
folder, just to make sure I was not including the wrong header files,
linking to the wrong libraries, or calling the wrong version of


Thanks for any help.



Reply via email to