I have some troubles with Postgre's JDBC driver, version 7.1.2.
First, I was not able to build the driver because it always tries to
compile the version for the Enterprise Edition Java Virtual Machines,
although I only have a Standard Edition instaled in my computer (a Red Hat
7.0 linux box).
   I could only compile it when I manually edited the  build.xml file, so
it right guessed the version of my Java VM.
   I thought I was done when the driver worked for the first time, but
sometime later I realized that the BLOBs I've imported from a Postgres
7.0.3 (using a java program and LargeObjectManager API) were all corrupt!
All BLOBs have only 19 bytes!
   I tested it with a  servlet  that runs fine with 7.0.3, and it just
thrown a NullPointerException somewhere (I couldn't check where exactly it
happens yet). After, I put the servlet to run with the old 7.0 JDBC
driver, but connectiong with postgres 7.1.2, and it worked fine
(ooops... not so fine, the BLOBs were all corrupt!)
   Is there any trouble with the JDBC driver that comes with 7.1.2 ?  Or
maybe something got wrong when I edited build.xml ?

                                          Any Ideas ?

---------------------------(end of broadcast)---------------------------
TIP 1: subscribe and unsubscribe commands go to [EMAIL PROTECTED]

Reply via email to