I can't seem to make a connection to my postgresql database from 
WebObject's EOModeler.  I'd like to rule out the possibility that the 
driver did not load properly.  If I type

java -Djdbc.drivers=org.postgresql.Driver example.ImageViewer

and I get the following text, then that means that my driver loaded 
properly, correct?

. . . This example tests the large object api of the example. . . .

If the driver loaded properly, and assuming that I started postmaster 
with the -i option for tcp/ip connections, which I did, then as I see 
it there are probably only two remaining reasons why I can't make a 
connection:  either the driver is not in the classpath (it is), or 
I'm not typing in the url correctly.  I've tried these three 
variations (the text below is *exactly* what I type; my database is 
called 'testdb'):


My connection window gives me the option of specifying the name of my 
driver.  When I type in


then I get an error message saying that it couldn't find 
postgresql.jar in the classpath and that I should check the 
classpath.  But in that same error window displayed in the classpath 
list is the path to postgresql.jar

Any tips. Thanks in advance.


ps  I'm running mac os 10.0.4 (Darwin), postgresql 7.1.2, and 
WebObjects 5.0 (just the EOModeler so far)

---------------------------(end of broadcast)---------------------------
TIP 2: you can get off all lists at once with the unregister command
    (send "unregister YourEmailAddressHere" to [EMAIL PROTECTED])

Reply via email to