Neil Conway <[EMAIL PROTECTED]> writes:
>> For ExecTypeFromTLInternal, maybe use ExecTupDescFromTL, which is a
>> more accurate name in the first place

> What's the logic in having ExecTypeFromTL() and ExecCleanTypeFromTL()
> implemented in terms of a function called ExecTupDescFromTL()? i.e. if
> we're going to be renaming functions, wouldn't it make sense to rename
> the public API functions, not the internal static functions?

My point was that you intended to export ExecTypeFromTLInternal in order
to convert the other names to macros, and I didn't want an exported name
like that.

The number of call sites seems small enough that altering the API isn't
out of the question either, if you like that better.

                        regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 8: explain analyze is your friend

Reply via email to