Another issue: I like the has_role() function and in fact think it needs
to come in multiple variants just like has_table_privilege and friends:

        has_role(name, name)
        has_role(name, oid)
        has_role(oid, name)
        has_role(oid, oid)
        has_role(name)          -- implicitly has_role(current_user, ...)

However I'm a bit dubious about whether "has_role" isn't an invasion of
application namespace.  pg_has_role would be better, but we have the
(mis) precedent of has_table_privilege.  What do you think about calling
it "has_role_privilege"?

                        regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 2: Don't 'kill -9' the postmaster

Reply via email to