Tom Lane wrote:
> Alvaro Herrera <[EMAIL PROTECTED]> writes:
> > This patch allows pg_regress to be installed by default.  This was
> > proposed awhile back but never done, any objections if I commit this?
> 
> I've forgotten the details, but it seems like there was something else
> that this depended on to be of any use?  What are you envisioning people
> doing with it?

Actually it works, as you discovered some time ago, using PGXS.  I use
it to test PL/php.  (Yes, I'm hacking on that ugly thing.)  I think
other module authors would also have some sort of regression testing;
having this in place eases things a bit.

I guess people whose packages need to support systems without PGXS
already have some testing harness in place, so it will be less useful to
them.

> BTW, I think you need an uninstall target too.

Ok.

-- 
Alvaro Herrera                                http://www.CommandPrompt.com/
The PostgreSQL Company - Command Prompt, Inc.

---------------------------(end of broadcast)---------------------------
TIP 5: don't forget to increase your free space map settings

Reply via email to