On Fri, Nov 28, 2003 at 01:18:48PM +0800, Christopher Kings-Lynne wrote:
> >Any thoughts?
> Actually, I ran my tests using tsearch V1.  I wonder if there has been 
> some weird regression between tsearch 1 and 2?

Maybe. tsearch2 doesn't seem production ready in other respects
(untsearch2.sql barfs with 'aggregate stat(tsvector) does not exist'
and the openfts mailing list, where this would be more appropriate,
doesn't appear to exist according to sourceforge).

So, using the same data, modulo a few alter tables, I try tsearch, V1.
It's a little slower than V2, and again runs far faster without an
index than with it. Broken in the same way.

I have 7.2.4 running on a Sun box, so I tried that too, with similar
results. tsearch just doesn't seem to work very well on this dataset
(or any other large dataset I've tried).


---------------------------(end of broadcast)---------------------------
TIP 9: the planner will ignore your desire to choose an index scan if your
      joining column's datatypes do not match

Reply via email to