On 6 June 2013 10:37, kilon <theki...@yahoo.co.uk> wrote:
> When I was coding with python I used underscore instead of camel case.
>
> MorphWindow -> morph_window
>
> and I also like common lisp approach
>
> MorphWindow -> morph-window

This is my favourite naming scheme. It's problematic from a Smalltalk
syntax point of view because whitespace isn't required around binary
selectors. So "morph-window" means "send #- to morph with argument
window".

Fun and games ensue when you consider subtraction and negation - is
"3--4" "subtract -4 from 3" or "send #-- to 3 with argument 4"?
(Squeak requires you to rewrite the code to either "3 -- 4" or "3 -
-4").

frank

> I always found camel case very weird , since back in 1996 that i saw it used
> in C++. And even though I have grown up reading it , I am still find it
> difficult especially with lenghty code.
>
> Of course what happens in pharo should be a democratic decision, but I dont
> think allowing for freedom to choose is a bad thing.
>
> Thats how python works, and most programming languages. Only pharo / squeak
> than I know of foces usage of Camel case, and capitalisation of first letter
> in classes . Cant say i find it a good thing.
>
>
>
> --
> View this message in context: 
> http://forum.world.st/Pharo-dev-Lowecase-class-names-tp4690963p4691925.html
> Sent from the Pharo Smalltalk Developers mailing list archive at Nabble.com.
>

Reply via email to