> On 12 Oct 2016, at 8:09 , Denis Kudriashov <dionisi...@gmail.com> wrote: > > > 2016-10-12 20:06 GMT+02:00 stepharo <steph...@free.fr > <mailto:steph...@free.fr>>: > In fact I do not really like iconNamed: as a name for a setter (for menu > items and settings) > May be it should be iconSelector: or buildIconNamed: > because else we will confuse iconNamed: which returns an icon and iconNamed: > that just sets the selector to retrieve the selector. > > What do you think? > > maybe #iconName:?
Isn't this exposing internal implementation details in the external API? The end result is a menu or a setting displayed with the corresponding iconNamed: associated, no? Cheers, Henry
Description: Message signed with OpenPGP using GPGMail