This is fun because
when I read col readStream
it takes me some milliseconds to process more than
ReadStream on: col
now if the other smalltalk use readStream and writeStream we should
keep it like that because
it is a minor point.
Stef
On Sep 4, 2009, at 12:04 AM, Henrik Johansen wrote:
> In VW, the methods are called readStream and writeStream.
>
> Personally, I prefer that, as a method starting with as... to me
> indicates having created a new equivalent object, not just a wrapper
> which is used to access the original object.
> There's a big difference between calling f.ex. _as_Array on an
> SequenceableCollection, then messing with the elements of the object
> returned, and doing the same with a method called asReadStream.
>
> Cheers,
> Henry
>
> On Sep 3, 2009, at 4:46 13PM, Peter Hugosson-Miller wrote:
>
>> I don't know how this is done in VW, but in any case I would also
>> prefer the method to be called #asReadStream, since it more clearly
>> expresses the fact that there is a conversion happening.
>>
>> In the same way, I would like to suggest the method
>> SequenceableCollection>>#writeStream would be better named
>> #asWriteStream, and I also think that the creation of a new method
>> SequenceableCollection>>#asReadWriteStream would be a good idea.
>>
>> --
>> Cheers,
>> Peter
>>
>> On Thu, Sep 3, 2009 at 4:32 PM, Stéphane Ducasse <[email protected]
>> > wrote:
>> I'm integrating your changes.
>> Now I was wondering if somebody knows if it VW we get readStream too
>> because I would prefer to have a better message than readStream
>> aCol asReadStream ?
>>
>> What do you think?
>>
>> Stef
>>
>>
>>
>> On Sep 2, 2009, at 9:59 PM, Peter Hugosson-Miller wrote:
>>
>> > On Wed, Sep 2, 2009 at 9:30 PM, Adrian Lienhard <[email protected]>
>> > wrote:
>> > Welcome, Peter!
>> >
>> > When you commit a change it would be good to also open an issue
>> in the
>> > tracker (and tell there which slice this is and in the slice
>> comment
>> > say which issue number it is). Like this it is easier to keep
>> track of
>> > changes.
>> >
>> > Cheers,
>> > Adrian
>> >
>> > Strange, I thought I had done that, but it was probably just the
>> > wrong part of the system (I'm just learning).
>> >
>> > This is the issue I created for the slice:
>> > http://code.google.com/p/pharo/issues/detail?id=1144
>> > so could you please tell me what I should have done instead (or as
>> > well ;-))?
>> >
>> > Thanks in advance,
>> > Peter
>> > _______________________________________________
>> > Pharo-project mailing list
>> > [email protected]
>> > http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
>>
>>
>> _______________________________________________
>> Pharo-project mailing list
>> [email protected]
>> http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
>>
>> _______________________________________________
>> Pharo-project mailing list
>> [email protected]
>> http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
>
> _______________________________________________
> Pharo-project mailing list
> [email protected]
> http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
_______________________________________________
Pharo-project mailing list
[email protected]
http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project