> You didn't understand me. When not to call it agressiveClean instead of 
> having a fac.. boolean and having to do
>  aBoolean ifTrue: [ blah blag]  ifFalse: [ blah blah blah] 
> 
> There is something I don't see ? I would have:
> 
> cleanUp
> 
> agressiveCleanUp
> 
> where this last one, may call cleanUp too 
>  
discuss with luc
and indeed it looks a bit over-engineered for what it does.

CleanUp and cleanUp are not connected have a look at the logic.
We are not bound to stick with it. If you have something better we can change 
without any problem.

Stef
_______________________________________________
Pharo-project mailing list
[email protected]
http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project

Reply via email to