David Foster wrote:
> There have been a number of mails about the SQLParamData error when starting
> Apache after installing the solid database installation. Here is a list of
> the actions we had to take to get solid working correctly with PHP 4.04pl1 I
> hope it saves some time since it cost us a lot !

This problem has been worked upon, and believed to be solved.  Several
test on FreeBSD, and various Linux flavors have resulted in clean
> Solid version is the current linux version 3.5 with glibc2

Please be sure to have the latest build libraries from Solid.  There is
a bug in the release form of their libraries which excludes many
important functions.
> In the include directlry of solid sqlunix.h change
> #include <wcstr.h>
> to
> #include <stdlib.h>
> Seems like the call to wcstr.h is an old call. The compilation will then
> work.

While this is something I have discussed with the SolidTech support
people, it is generally believed to be "a bad idea."  Even worse is the
fact that wcstr.h does not exist on many platforms, and should actually
be wchar.h (NOT stdlib.h).  SolidTech has not been able to give me an
answer with regards to this, except for:

"sqluinix.h should have lines like this:
#elif defined(SS_LINUX) && !defined(SS_MT) && !defined(SS_LINUXLIBC6)
#include <wcstr.h>
Further the second level support would like to know whether you tried

SS_LINUXLIBC6 does not exist in the 3.5x systems, and is part of the 3.6
system, so this has left me with a pretty much useless answer.  The
stdlib.h apparently does not support many of the unicode functions
(properly), to which SOLID has moved all internal functionality to. 
This will cause problems.  :\
> In the solid lib directory make symlinks like this:
> ln -s socl2x35.a libsocl2x35.a
> ln -s socl2x35.so libsocl2x35.so
> The standard installation doesnt include these. Not 100% sure they are
> really needed but we got linker errors.
> Finally put the path to those libs in LD_LIBRARY_PATH or edit
> /etc/ld.so.conf (don?t forget to run ldconfig after).

Not sure if you need to add them to the ld.so.conf, but I'm not
generally a Linux user...  I would think the ODBC_LFLAGS statement
should remove the need for doing this though.  
> Now the PHP problem. After solving these problems you get the SQLParamData
> error when loading apache. Seems like there is a script error in ./configure
> There is a test in this file for the existence of the solid files after
> which there are several echo statements if there is a problem (you can
> pretty much search for these in the file). On the last echo statement the
> "else" clause is on the same line and is ignored. Unfortunately the else
> clause contains the linker statements and is ignored. Hence the error.
> Putting the else on a new line fixes the problem. You can see if you have
> this problem when you run configure. You may get the message "Finding Solid
> Library ..." but no error and nothing after the dots.

I have looked at the config.m4 (the file that helps generate the
./configure script for the ODBC module), and do not see the else
statement being ignored.  This was a problem on the 4.0.4 release
(forgot a line break), but I believe the patch made it into the

If you can, please try the latest snapshot from CVS and see if this
problem still exists for you.  I was under the impression that much of
this has been fixed for linux as well (I've had several users report
this problem gone, including the original submitters).

Dan Kalowsky                  "Tonight I think I'll walk alone, 
Worldgate Communications       I'll find my soul as I go home."
Software Engineer - TICS Group          - Temptation

PHP Database Mailing List (http://www.php.net/)
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to