I think it's more likely that you haven't sourced the 
/home/db2inst1/sqllib/db2profile script in whatever wrapper script starts 
up Apache for you. Add the following line to the top of 'apachectl' or 
'/etc/rc.d/init.d/httpd' to set up the DB2 environment variable before you 
start your webserver:

. /home/db2inst1/sqllib/db2profile


ManieQ wrote:

> OK, here are some important details about my system:
> 1. Linux (Mandrake 7.2)
> 2. Apache 1.3.14 (from distribution)
> 3. jre118 (rpm, IBM version)
> 4. IBM DB2 V7.1
>    Installed with default logins, directories, etc.
> 5. Added '/usr/IBMdb2/V7.1/lib' to '/etc/ld.so.conf'; 'ldconfig' executed
> 6. PHP 4.0.3pl1
>    From source rpm, but compiled manually (not rpm build).
>    I used '--with-ibm-db2' option and also some others like
> '--with-apxs --with-ldap' etc.
> 7. Modified apache conf to use PHP.
> I'm sure libdb2.so is used, because when I remove (5) line from
> 'ld.so.conf' I cannot start apache (missed library). Also tried
> '/home/db2inst1/sqllib/lib'
> - no result. Tried to start apache as db2inst1 user (http.conf -> User)  -
> still
> nothing.
> So, I still think about DB2 version incompatibilities.

PHP Database Mailing List (http://www.php.net/)
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to