my unixODBC-2.2.2 installation works fine. I tested the configuration with a 
local and a remote ressource to a Sybase Adaptive Server Anywhere database with 
isql (a testing tool of unixODBC). Thus the settings in the odbc.ini and 
odbcinst.ini should be correct. But when I'm using PHP-4.2.1 with 
unixODBC-support, I can connect to the local ressource only, not to the 
remote-ressource, although it worked with isql. Do you have any general ideas, 
why it doesn't work?

Are there known issues about the unixODBC-implementation in php? PHP always says 
"unable to connect to server: database not found". But as I told before, the 
odbc.ini settings are correct. It seems that php tries to connect to a local 
server although in odbc.ini CommLinks-settings are defined. Does maybe php don't 
receive the odbc.ini data correct? I thought that it might be a permission 
problem, but I ran apache 1.3.26 (with php as module) with the same user to whom 
all the files and databases belong and I got no positive result.

Marten Lehmann

PHP Database Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to