On Wednesday 24 July 2002 11:38, Ruth Zhai wrote:

> We just upgraded our PHP to version 4.2.1.  I realized that $var is no
> longer available from www.url.com/myphp.php?var=3 .  As instructed in the
> document, we have tried two things:

Good, someone who reads the docs :)

> 1. I tried to use $_GET('var'), however, I got "Fatal error: Call to
> undefined function: array() in /home/httpd/... " message.  I have no clue
> what this means, and what I have done wrong.

It should be $GET['var'].

> 2. Set register_globals = on in the configuration file.  This did not make
> any difference.

Did you restart the webserver? 
Did you make sure you're editing the correct php.ini? Check using phpinfo().

Jason Wong -> Gremlins Associates -> www.gremlins.com.hk
Open Source Software Systems Integrators
* Web Design & Hosting * Internet & Intranet Applications Development *

Serocki's Stricture:
        Marriage is always a bachelor's last option.

PHP Database Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to