While viewing web pages, we sometimes get the following error: "Warning:
mysql_pconnect: Link to server lost, unable to reconnect in
/home/dratner/includes/common.inc on line 26 ". The offending line is this
code:
                                 if (!$db = mysql_pconnect("db1", "diadba",
"c0s3mST"));

This line is in our common include file. It is supposed to create a
connection to the database and return an error if the connection fails. It
usually works, but sometimes we get the above error. Refreshing the page
makes the error go away, but that is not a very good solution, and we need
to figure it out before we lauch our site.

Configuration:

We are running 4.3.0RC2 and MySQL 3.23.53A on Linux 8.0. Our PHP server is
connected directly to the MySQL server via a cross-connect cable. So these
two machines have a private 100Mb connection used exclusivly for database
communication. We are currently developing an auction.

Since we are currently in development there are only two or three people
accessing the site. We are worried that the problem will get worse when the
we launch our application and we have a real work load on the server.
I would greatly appreciate any help that anyone could offer. I just can't
figure out why we sometimes have trouble connecting, especially with the
load on two large servers being so tiny.

        Don! Briggs

        [EMAIL PROTECTED]



-- 
PHP Database Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to