Hello!

I set up PHP on a Sun Solaris box a week ago (see phpinfo output below).
  It has oracle 7.3.4 and php 4.0.4pl1 so I'm using the --with-oracle
configure option.  Due to a special module we're using we're stuck with
using that php version (4.0.4pl1).

At first I was getting the ORA-12154 TNS:could not resolve service name
error almost every time.  I then followed the instructions to set the
ORACLE_HOME and TNS_ADMIN environment variables in apaches http.conf.
I've also tried using the putenv function to set the variables.

This really improved the situation but when I found it was still not
working I wrote a small java program that calls the php page every 15
seconds.  About 10% of the time I get the TNS (ORA-12154) error but the
other 90% it works perfect.  This applies both to selecting and
inserting data.

-- partial output from phpinfo() --
System SunOS red 5.7 Generic_106541-15 sun4u sparc SUNW,Ultra-250
Build Date Jan 29 2003
Configure Command './configure' '--with-apxs=/opt/apache/bin/apxs'
'--with-mysql=no' '--with-oracle=/opt/app/oracle/product/7.3.4/'

oracle
Oracle Support enabled
Oracle Version 7.3
Compile-time ORACLE_HOME /opt/app/oracle/product/7.3.4/
Libraries Used

I really need to get this working so all ideas would be appreciated.

Best regards,

Maron Kristˇfersson
ReykjavÝk
Iceland


--
PHP Database Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to