Thanks for all the help everyone sent me on this. However, nothing seems to
make any difference whatsoever (except putting the 'localhost' part in
quotes). I am still getting permission denied errors based on the user

I have entered a user into the user table with host='localhost', user='php'
and a password.
I have entered these credentials into the db table also, and given the
various privileges for this user to the specific database.
I have run both mysqladmin reload and mysqladmin flush-privileges.
I have even rebooted the machine.
I have also tried typing GRANT SELECT,INSERT,DELETE,UPDATE TO php@localhost
IDENTIFED BY *******, but this just throws up an error at the MySQL prompt.

My PHP page can still not connect to the database. It just says:

MySQL Connection Failed: Access denied for user: 'php@localhost' (Using
password: YES)

I know the problem is a permissions thing, because if I connect to the test
database as 'nobody', there is no problem.

Again, any and all help will be appreciated. This is ridiculously
frustrating, especially since I have no problem connecting to the database
from a perl script. I am tempted to stop trying to learn PHP and build my
entire web site using perl cgi instead.


Evan Morris
Tel: +27 11 792 2777
Fax: +27 11 792 2711
Cell: +27 82 926 3630

PHP Database Mailing List (
To unsubscribe, visit:

Reply via email to