Stuart Kendrick wrote:
hi chris,

right. if i run 'psql -d soma' and then type the first SELECT, i get results ... if i type the second SELECT, i get zero rows. this seemed odd to me ... i wouldn't think that postgres would care. but perhaps it does

hmm. ok, i just tried this again ... and now i'm getting results, no matter whether i include single quotes or not, in the syntax of the SELECT

and ... now i'm getting the same results, from both the psql interface *and* from my php interface

so. where does this leave me. was i hallucinating a few days ago? i find that hard to believe -- i spent a couple hours building that post, along with all the supporting traces

ok, if this effect were continuing ... where the single quotes mattered ... what would that lead you to suggest? some issue inside PostGres itself?

Well you'll probably need quotes around the date otherwise it could be interpreted as

2006 -
0008 -
0014
====
...

because you can use math functions in where clauses etc.

The quotes around the int field shouldn't matter however.

--
Postgresql & php tutorials
http://www.designmagick.com/

--
PHP Database Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to