<STUPID>
When I used MySQL Administrator User Administration Add host ... I assumed
the same priveleges carried to the added host.  That was a stupid
assumption.
</STUPID>

Chris and Micah,  Thank you so much.  I wouldn't've discovered it for days
... maybe even weeks ... without your prodding.

""Stan"" <[EMAIL PROTECTED]> wrote in message
news:[EMAIL PROTECTED]
> UBUNTU Server v8.04
> On a web page:
>
> CODE:
> require_once 'frames_includes/navigationDB.inc';
> $navigation_connection = mysql_connect($navigation_hostName,
>                                        $navigation_userName,
>                                        $navigation_passWord)
>   or
> die("Failed to connect to MySQL on the nasServer ... call Stan");
> mysql_select_db($navigation_databaseName,$navigation_connection)
>   or
> die("Selection of 'navigation' database failed ... call Stan");
> $navigation_data = mysql_query("SELECT * FROM " .
>                         $navigation_databaseName . ".navigate " .
>                         "ORDER BY navigateHandle",
>                         $navigation_connection)
>   or
> die("SELECT * FROM navigate table failed ... call Stan");
> END CODE:
>
> works when the UBUNTU server is attached to the same subnet as the MySQL
> server.
>
> If I move the UBUNTU server to a different subnet (through an ipCop
> machine), making appropriate adjustments to network configuration,
including
> punching a hole in the firewall for port 3306 from the UBUNTU server to
the
> MySQL server and authorizing the user at the new IP to MySQL, the
> mysql_connect works but the mysql_select_db fails.
>
> I need help debugging this, please?
>
> Thanks,
> Stan
>
>



-- 
PHP Database Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to