On Tue, Dec 9, 2008 at 10:33 AM, Alex Moen <[EMAIL PROTECTED]> wrote:

> OK, sounds good, what am I looking for?  I don't see the module being
> declared in my php.ini file on either of my servers.
> Alex
> Fortuno, Adam wrote:
>> Alex:
>> It sounds like the MySQL extension module isn't loading. Here are some
>> things to confirm:
>>  - Ensure the module is declared in your php.ini file
>>  - If it exists in the php.ini, confirm the module is located and named
>> as stated in the php.ini file.
>>  - If the module is named and located in the proper place, check your
>> permissions on that extension. You want to make sure whatever is running
>> your sight can access the module.
>> I hope this helps!
>> A-
>> -----Original Message-----
>> From: Alex Moen [mailto:[EMAIL PROTECTED] Sent: Tuesday, December 09, 2008
>> 9:54 AM
>> To: php-db@lists.php.net
>> Subject: [PHP-DB] Yet another Call to Undefined Function help request
>> Hi all,
>> PLEASE, don't just toss the e-mail... I think I have a unique enough
>> situation to warrant this e-mail.
>> First, I have searched the mailing lists for the answer to my problem.
>> I have also tried to find the answer through the documentation, but have
>> been unsuccessful.  Mailing lists are always my last resort.
>> Here's the situation.  I have an *old* Cobalt Raq appliance with Apache
>> 1.3.20 and an older version of mysql on it.  I have a customer that
>> wants to use a database on his website, and rather than update this old,
>> unsupported appliance and possibly break something, or go through the
>> hassle of moving this customer with 100+ e-mail addresses to a different
>> server, we have
>> installed a new, dedicated mysql server to use system-wide for any of
>> our customers, and ourselves, to use as a db server.  This seemed like a
>> good idea at the time, and I think it will work well once we figure out
>> the bugs here.
>> Now, everything was going swimmingly, until we tried to access the db
>> with php on a web page (which is where we got the call to undefined
>> function). It was an old version of php, so I thought I'd upgrade, not as
>> scary as
>> upgrading all three pieces of software.  No resolution there.  I
>> compiled it with mysql support, but still get the undefined function
>> error.  Now, on
>> the new db server, phpinfo reports a whole section on mysql.  On this
>> older server, there is no mysql section in phpinfo.  I can log in and
>> access
>> the databases remotly from the Cobalt server using command line mysql; I
>> would like to try this at cli using php but don't know how.
>> I am obviously missing something and I can't find the answer anywhere,
>> other than "reinstall apache, mysql, and php", which is kind of scary on
>> a server this old that is running as well as it is.  Not only that, but my
>> ego is kicking in here and I would really like to understand what the
>> problem is rather than just reinstalling everything... That just seems too
>> M$ to
>> me.
>> Any suggestions?
>> Thanks,
>> Alex
> --
> PHP Database Mailing List (http://www.php.net/)
> To unsubscribe, visit: http://www.php.net/unsub.php
In the new version of php, mysql is not enabled by default. Check the ini
file for the modules section and ensure that the mysql is uncommented.



Cat, the other other white meat

Reply via email to