ID: 8791
User Update by: [EMAIL PROTECTED]
Old-Status: Feedback
Status: Open
Bug Type: Reproduceable crash
Description: core dump when trying to get_class_vars on a class with a hash variable

Nope.  Must've been fixed between 4.0.3pl1 and 4.0.4pl1 because it doesn't core dump 
after upgrading.  I'm still not sure it does what I'd expect, though, since in my 
example, I'd expect printing $val to output "Array" but it doesn't output anything.  
If I print_r($val) it does show the contents of the array though.  That's definitely 
good enough for what I'm trying to do, but it seems like it's not 100%.  Thanks a lot 
for the help!

Previous Comments:

[2001-01-19 21:35:53] [EMAIL PROTECTED]
Does this happen with PHP 4.0.4pl1 ? I tried with latest CVS and it didn't crash.



[2001-01-18 13:37:28] [EMAIL PROTECTED]
class xyz {
        var $x = array('a' => 'df', 'b' => 'dd', 'c' => 'fd');
$arr = get_class_vars('xyz');
while(list($key,$val) = each($arr)) print "Properties $key has value : $valn";

 './configure' '--with-mysql=/usr/local/mysql' '--enable-track-vars' '--without-gd' 
'--with-xml' '--without-ldap' '--without-imap'

Sorry, I couldn't get a gdb backtrace because my php wasn't compiled with the debug 
stuff turned on.  I suspect that you'd be able to reproduce this easily though.  Let 
me know if you need any more information from me.


Full Bug description available at:

PHP Development Mailing List <>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to