ID: 9058
User Update by: [EMAIL PROTECTED]
Old-Status: Feedback
Status: Open
Bug Type: Directory function related
Description: dir() and readdir() don't work

Oops, a big sorry, that should be HP-UX 10.20, NOT Solaris 8 - Solaris is OK.

I updated from CVS about 3 hours ago, and tried that.  It still doesn't work on HP-UX. 
 The compiler used is gcc 2.8.1
I'm willing to try a more recent version if that will help.

I would have tried to trace (like truss) the httpd process but I can't get a working 
trace on this backward (HP-UX) O/S :-(



Previous Comments:

[2001-02-01 20:19:05] [EMAIL PROTECTED]
I tried them examples in our Solaris 8 (sparc) with the latest CVS
and they worked just fine. 

Could you try the latest CVS snapshot from  
to verify if this is fixed already? And which compiler did you use to compile PHP ?

I'm using GCC 2.95.2 as we don't have that Sun Workshop CC installed
in that machine yet.



[2001-02-01 16:53:09] [EMAIL PROTECTED]

Using the examples cut-n-pasted from the dir() and readdir() documentation, dir() they 
both return nothing.  They work ok in php3.

I see other entries in the bug database saying this issue was fixed in the cvs, but 
these are dated before the release of the version I'm using, so I guess they became 
broken again or Solaris 8 is a problem.

I'll be delighted to help debug this if someone can tell me how.

Best Regards,



Full Bug description available at:

PHP Development Mailing List <>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to