On Fri, 16 Mar 2001, yavo wrote:

>On several occasions I had to install php with oci8 on redhat Linux (6.2)
>with different versions of apache 1.12 - 1.17 with Oracle 8.1.6 client .
>Every single time I get the same thing. Apache shows no errors, the apache
>start script shows no errors but dies without an error. This only happens
>when the oci8 extension is enabled.I've tried anything I could. I've put the
>oracle variables in any place I could think of (except one) in the
>environment rc files, in httpd.conf file with SetEnv directives and in the
>apachestl file. The variables I export are ORACLE_HOME LD_LIBRARY_PATH and
>ORACLE_SID . Can someone tell me what condition would cause oci8 to die. I'm
>I doing something wrong. It's been many hours and I'm getting frustrated.
>I've tried the following things
> Oracle Client 8.1.3 + Apache 1.17 | Apache 1.19 + Php 4.0.4pl1 | Php
> Oracle Client 8.1.2 + Apache 1.14-5 (comes with RedHat 6.2) | Apache 1.19 +
>Php 4.0.4pl1

Most likely your Apache isn't linked with libpthread.
Check the manual page http://www.php.net/oci8 for information
about how to link apache with phthread library.


PHP Development Mailing List <http://www.php.net/>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to