ID: 10741
User Update by: [EMAIL PROTECTED]
Old-Status: Open
Status: Closed
Bug Type: PCRE related
Operating system: FreeBSD 4.3
PHP Version: 4.0.5
Description: ereg "-" problem only on 4.05 - critical!

ok now the interesting part. As mentioned in the regex dox, "use - at the beginning or 
at the end.." it works.

So far, so good - but, the regular expression worked before without this (necessary) 

Interesting point. After rewriting some of my sources now everything works again, 
sorry for bothering anyone.

Maybe it has something todo with my FreeBSD update from 4.2 to 4.3 (regex lib?) I 
donīt know.

Previous Comments:

[2001-05-08 20:30:05] [EMAIL PROTECTED]
After updating from 4.04x to 4.05 i noticed a problem with regular expressions.

regular expression:


should normally find this:

using ereg(i) command - but no chance.

If I delete this: "-" (cgi-local to cgilocal) it works.

The regular expression worked with 4.04x and since updating it does not work any 

I think its a "critical" bug.

Interesting is that I have only probs with "-", but it seems to be that there are some 
more problems with another regular expression I had no time to analyze yet.


Full Bug description available at:

PHP Development Mailing List <>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to