ID: 10945
User Update by: [EMAIL PROTECTED]
Status: Analyzed
Bug Type: Apache related
Operating system: AIX 4.3.3 (MU8)
PHP Version: 4.0.5
Description: Apache core dumps when PHP4.0.5 is activated via LoadModule

Tried recompiling everything with IBM Visual Age C v5.01.  No change.  I also tried 
linking with the pthread library for the httpd binary, like [EMAIL PROTECTED] said to 
try, but no luck.  Quick question: is AIX on the "supported" list ??  Is this supposed 
to work ??


Previous Comments:

[2001-05-17 21:49:55] [EMAIL PROTECTED]
On systems that use glibc-2.1.x there is a bug in glibc that prevents a binary not 
linked against pthreads to dynamically load a shared library that is linked against 
pthreads.  Perhaps this problem also exists on AIX?  Try linking your Apache httpd 
against libpthreads.


[2001-05-17 20:57:44] [EMAIL PROTECTED]
Apache-1.3.19 compiles clean under gcc-2.95.3 with:

$ ./configure --prefix=/opt/apache --enable-module=so
<junk deleted>
$ make
<junk deleted>
# make install
<junk deleted>

Apache starts cleanly and generally works fine.

PHP4.0.5 compiles clean under gcc-2.95.3 with:

$ ./configure --prefix=/opt/php --with-apxs=/opt/apache/bin/apxs 
<junk deleted>
$ make
<junk deleted>
# make install
<junk deleted>

Howver when I stop Apache and start it back up again, it doesn't start.  It dumps 
core.  When I rem out the LoadModule directive for the php module in httpd.conf, 
Apache starts up fine.

[ FYI: it's MySQL 3.23.34a (--prefix=/opt/mysql --with-pthreads) ]

Any suggections on how to troubleshoot it ?  If you have a use for the core, I can 
send it to you.  More info:

AIX 4.3.3 (maintenance update 8)

Only other software installed on the system is GNU make-3.79.1 and bash-2.04.

Any help is greatly appreciated.


Full Bug description available at:

PHP Development Mailing List <>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to