ID: 11000
User Update by: [EMAIL PROTECTED]
Status: Open
Bug Type: FTP related
Operating system: NT 4.0
PHP Version: 4.0.4pl1
Description: ftp_connect(...) produces ftpbuf 0 "error"

Now the third answer for [EMAIL PROTECTED] (Hi Jani, I saw your question unfortunately 
just after I sent my last report):

I used the ftp-server WAR-FTPD 1.67-05 (freeware, downloadable from and tried it localy installed on my NT4.0 Worsstation with an 
external NT4.0 Intranet-Webserver (Apache with PHP 4.04).At home I used a Windows 2000 
Workstation with local running Apache and PHP 4.0.4 first, 4.0.5 after a meanwhile 

The original error-message on all configurations was:
"Warning: Unable to find ftpbuf 0 in e:\eigene dateien\php\liegenschaften\upload.php4 
on line 10"

Some new information:
To my surprise this error does not occur at home, when I am connected to Internet. 
After dialing in the script runs also with "" without any warnings, after 
shutting down the Internet-connection only $ftp_server = "localhost" or 
$ftp_server="#DNS_name_of_server#" is accteptd.
This is also the reason for my second "workaround" as described before, this is no 
one, because '' is only accepted when internet-connection is open.

Hope, this will help you!
bye... kni

Previous Comments:

[2001-05-21 21:15:19] [EMAIL PROTECTED]
Send this bug-message this morning, got two answers myself this evening:
Obviously php does not understand ftp-server-adresses in form of "" or 
somehow, but when I used "localhost" or the name of the server defined in the 
Apache-Konfiguration the script below ran without any error-message. 
Another workaround: using '' ran also without problems!?!


[2001-05-21 16:45:19] [EMAIL PROTECTED]
Have you tried with some public ftp-server?
Does it work then? And what is the full error message?



[2001-05-21 15:39:36] [EMAIL PROTECTED]
I installed the PHP4 software (actual Windows binary 4.04pl1) with the actual 
Apache-Server on a NT 4.0 server. The FTP-Server I try to contact runs localy on my 
NT4.0 PC.
The following script
$ftp_user = "username";
$ftp_pass = "password";
$ftp_server = "";
$conn_id = ftp_connect("$ftp_server");
echo $conn_id;
$login_result = ftp_login($conn_id, "$ftp_user", "$ftp_pass");
causes "Warning: Unable to find ftpbuf 0 in ....".
$conn_id is null, it seems, that there is no connection.
I found some similar error-messages in the php-FAQ's, but no answer.


Full Bug description available at:

PHP Development Mailing List <>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to