Hi,
> force a prefix onto the variable name. I.e.,
> import_globals("GPC", "form_");
I like this idea (the whole idea of import_globals is good, I think, but I'd
rather call it accept_globals, but more on that later :), only this would
make it difficult to actually differentiate between get, post and cookie,
needing import_globals("G", "get_"); import_globals("P", "post_"); and
import_globals("C", "cookie_"); if that was needed.
I would like to see it implemented something like
accept_globals("GPC", 'user', 'password', 'value_*', 'more');
where you can specify both complete names and wildcards, even though I'd
like a better range-check for the wildcard, perhaps something like
value_[0..12].
About accept_globals, I think that a newbie might see import_globals as a
necessary step to get things to work (which it is), and not think about it
any more. If you alter the function name, people might think a bit more?
import_globals: 'OK, if I want to use this variable, I need to import it'
accept_globals: 'OK, if I accept this variable, I must also check its
validity'
To be honest, I would like accept_user_globals even better...
Just another 2 cents :)
Cheerio, Marc.
--
PHP Development Mailing List <http://www.php.net/>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]