ID: 12283
Updated by: sniper
Old Status: Open
Status: Bogus
Bug Type: HTTP related
Operating System: Linux 2.2.16-22 (RedHat 7.0)
PHP Version: 4.0.6
New Comment:

user error

Previous Comments:

[2001-08-19 08:07:16] [EMAIL PROTECTED]

I tried it again with the same script on my home configuration (linux RH 7.0 + php 
4.06) and it worked after increasing the max file size. I made a mistake in the file 
size, i.e. overlooked a 0 I think :-(
I'm sorry for the commotion. You can close this bug report.


[2001-08-19 06:48:11] [EMAIL PROTECTED]

Next question is: Does this happen with other browsers, like
with Netscape?


[2001-08-19 06:23:41] [EMAIL PROTECTED]

I did increase the size, but with the same results. I also tried other upload scripts 
from the internet, with mixed results (unpredictable) on different systems. And in my 
opinion the script I wrote is OK.
Could there also be a browser problem with Internet Explorer 5 and 5.5?


[2001-08-19 04:00:55] [EMAIL PROTECTED]

I would think a Word file is a lot bigger always than 1000 bytes.. So try changing 
that first.



[2001-07-20 10:11:35] [EMAIL PROTECTED]

I have a problem with file uploads on my PHP configuration. Some filetypes get 
uploaded (e.g. BMP, GIF, TXT), while others don't get uploaded (for example: MSWORD, 

I use the following testfiles:

  <title>Administration - upload new files</title>
<h1>Upload new news files</h1>
<form enctype="multipart/form-data" action="upload.php" method="post">
  <input type="hidden" name="MAX_FILE_SIZE" value="1000">
  Upload this file: <input name="userfile" type="file">
  <input type="submit" value="Send File">

<h1>Uploading file...</h1>
        echo "file: " .   $userfile . "<BR>\n";
        echo "name: " . $userfile_name . "<BR>\n";
        echo "type: " . $userfile_type . "<BR>\n";
        echo "size: ". $userfile_size ."<P>\n";

if(is_uploaded_file ($userfile))

  $upfile = "/home/projectweb/files/". $userfile_name;

  if ( !copy($userfile, $upfile)) 
    echo "Problem: Could not move file into directory"; 

  echo "File uploaded successfully<br><br>"; 
  $fp = fopen($upfile, "r");
  $contents = fread ($fp, filesize ($upfile));
  fclose ($fp);
  $contents = strip_tags($contents);
  $fp = fopen($upfile, "w");
  fwrite($fp, $contents);

  echo "Preview of uploaded file contents:<br><hr>";
  echo $contents;
  echo "<br><hr>";
        echo "There is no file uploaded!";


Result with a BMP file:

file: /tmp/files/phpNGn0H0
naam: at.BMP
type: image/bmp
size: 230
File uploaded successfully

Preview of uploaded file contents:

Result with a Microsoft Word file:

file: none
naam: Doc1.doc
type: application/msword
size: 0

There is no file uploaded! 

I'm puzzeled. Any ideas?


Edit this bug report at

PHP Development Mailing List <>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to