Quoting Sterling Hughes <[EMAIL PROTECTED]>:

>     Jep -- I'm writing PEAR OO wrappers for every ADT that I implement
>     in a functional manner.  I'm think for the OO wrappers, seperate
>     class names wouldn't be horrible, something like:
> 
>     $tree = new AVLTree;

Please stick to the naming conventions, which would make this:

$tree = new ADT_Tree_AVL();

... or something similar. Also, you could easily have a factory method:

$tree = ADT::factory('tree_avl');

or:

$tree = ADT_Tree::factory('avl');

-chuck

--
Charles Hagenbuch, <[EMAIL PROTECTED]>
Some fallen angels have their good reasons.

-- 
PHP Development Mailing List <http://www.php.net/>
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to