Hi all,

Calling function may become a problem also.
Any comments following changes?

Index: CODING_STANDARDS
===================================================================
RCS file: /repository/php4/CODING_STANDARDS,v
retrieving revision 1.12
diff -u -r1.12 CODING_STANDARDS
--- CODING_STANDARDS    14 Mar 2002 03:25:46 -0000      1.12
+++ CODING_STANDARDS    18 Mar 2002 06:28:08 -0000
@@ -66,6 +66,9 @@

  [8] Use assert(). assert.h is included in php.h if it is available. 
Not only
      does good assertion catch bugs, but it also helps with code 
readability.
+     - Do not use assignment in assert condition to avoid Heisenbugs.
+     - Do not use assert for error handling. Use assert only for the
+       condition that must be always true.

  Naming Conventions
  ------------------


--
Yasuo Ohgaki


-- 
PHP Development Mailing List <http://www.php.net/>
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to