Markus Fischer wrote: > I wouldn't uset the word Heisenbugs. Not every developer is > familiar with it. Do you think it's possible to use a more > descriptive sentence? >
Oh. I agree. How about - Do not use assignment in assert condition. If assignment is used, there is risk that we have disapearing bug with debug build due to side of effect of assignment. Function calls in assert condition may create this bug also when parameter or global variable is changed. I appreciate if someone could fix my bad English. -- Yasuo Ohgaki > - Markus > > On Mon, Mar 18, 2002 at 03:42:21PM +0900, Yasuo Ohgaki wrote : > >>Hi all, >> >>Calling function may become a problem also. >>Any comments following changes? >> >>Index: CODING_STANDARDS >>=================================================================== >>RCS file: /repository/php4/CODING_STANDARDS,v >>retrieving revision 1.12 >>diff -u -r1.12 CODING_STANDARDS >>--- CODING_STANDARDS 14 Mar 2002 03:25:46 -0000 1.12 >>+++ CODING_STANDARDS 18 Mar 2002 06:28:08 -0000 >>@@ -66,6 +66,9 @@ >> >> [8] Use assert(). assert.h is included in php.h if it is available. >>Not only >> does good assertion catch bugs, but it also helps with code >>readability. >>+ - Do not use assignment in assert condition to avoid Heisenbugs. >>+ - Do not use assert for error handling. Use assert only for the >>+ condition that must be always true. >> >> Naming Conventions >> ------------------ >> >> >>-- >>Yasuo Ohgaki >> >> >>-- >>PHP Development Mailing List <http://www.php.net/> >>To unsubscribe, visit: http://www.php.net/unsub.php > > -- PHP Development Mailing List <http://www.php.net/> To unsubscribe, visit: http://www.php.net/unsub.php