When I try to use PHP to send mail through qmail I get a "qmail-inject: fatal: read 
error".  I have read through the list and I have seen (and tried) the following 

1. Put /var/qmail/bin/qmail-inject into php.ini
2. Ensured that all appropriate sendmail links exist
2. Also tried the permutations of sendmail, and sendmail default etc in php.ini.
3. Tried (temporarily!) adding apache (web-server is run under user apache, group 
apache) to root group (only for testing - not advisable permanent solution).
4. I don't have anything calling QMAILMFTFILE  but I am not sure where this is called 
from.  It doesn't show in printenv.  Maybe someone could clarify this?  But I tried 
adding QMAILMFTFILE=/tmp/.lists to my apache start-up file just in case. 
5. Added user apache   group apache in httpd.conf before modules are called.

qmail functions well on my computer but it's not the problem in any case because the 
e-mail never enters the mail system.  The error mentioned above shows up in the Apache 
error-log.  PHP is also performing very well in every other capacity.

I know that there are many people experiencing this problem and some have given up on 
using PHP because they have to use the qmail system and some have had to go back to 

There have been a number of solutions given in this list and I have tried them all but 
none have worked.  Does someone have the definitive answer on this?

I am running Mandrake Linux 8.0 with PHP 4.0.4pl1 and Apache 1.3.19.

Reply via email to