For those who might run into the same problem in the future:

If functions like "mysql_db_name" are not working and you get no 
mysqlerr, then most likely your PHP installation is messed up. Maybe you 
see the same behavior than we: phpinfo shows old and wrong stuff in the 
first section, i.e. an old servername or the wrong PHP version even if 
you installed a different one. phpinfo must never show wrong information!
In our case PHP is static compiled with Apache, I guess the Apache 
installation was not clean either.

This kind of error is easy to see if you install phpMyAdmin: you do not 
even get the index page. We finally connected to a running MySQL 
database on a production server, got the same result and could therefore 
isolate the problem - PHP or the combination Apache/PHP.

We run Solaris 2.8 on a Netra T1 AC200 and we are not familiar to this 
system yet. And we did more than one installation on this machine, maybe 
one or more were not correct. Since a complete new install of 
Apache/PHP/MySQL on a other Sun (X1) worked, we knew what to do:
Delete all previous installations of Apache and PHP. Make a fresh and 
empty /usr/local/ directory. delete all config files you might have in 
different locations. Unpack the downloads - all latest stable - only 
with gtar (important!) and compile only with gcc (important!). Now we 
are up and running, just the PHP library for dynamic image generation 
could not been installed - we are working on it.

Richard Lynch, thank you for your help. Your guess that there are 
accidently different libraries involved, pointed us in the right 

Peter Ostry

PHP General Mailing List (
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]

Reply via email to