On Monday 18 March 2002 06:31, Markus Falk wrote:
> I run a script on my page that has worked fine before with 4.0.3 but now
> when my provider has upgraded to 4.1.2,  a bunch of error messages appear.
> I get some messages about variables not being defined just as if I can't
> send variables via the adressbar (/ ../index.php?$kat=0 for example. ) How
> come they suddenly appear as not being defined?
> I also get a lot of messages saying "PHP Warning: Undefined offset: 1 in
> /home/f/falk/public_html/index.php on line 148"
> What does it mean that I have an undefined offset?
> You can find all errormessages here http://www.acc.umu.se/~falk

Because in PHP 4.1.1+ the setting register_globals has been turned off by 
'default'. To access the variables passed through the URL you need to use 
$_GET[]. For your example above that would be $_GET['kat'].

Jason Wong -> Gremlins Associates -> www.gremlins.com.hk

When the English language gets in my way, I walk over it.
                -- Billy Sunday

PHP General Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to