I've been using PHP 4.0.1 for ages now, and have decided to upgrade one of
my machines to 4.2.1 and get used to working under the new security

I understand that older scripts are fully compatible with 4.1.0+, or can
be made
so with minimal fuss. I am assuming that scripts written using the new
$_GET and $_POST (etc) arrays simply won't run under pre-4.1.0 versions of

So, where does this leave us with regard to ISPs that still run older
versions of PHP (so that users' scripts won't break)? Is there some way to
write code using the new arrays, but that will run under older versions of
PHP. Would including something like this at the top of a script work:


while inside the code reference is made only to $_POST ? 

Sorry if this has been covered repeatedly, I've only just rejoined the
list after a break from the relentless volume (of great, useful info).

Michael Hall     [EMAIL PROTECTED]

PHP General Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to