William --

I've also spend a considerable amount of time trying to get this to
work on Redhat 7.2 (and maybe 7.1). I did a lot of coaxing and

Best I can say, it doesn't work with JDK 1.4. Once I tried 1.3.x,
everything went fine.

My guess is that something changed in the upgrade, but I don't have
time to figure out what.


On Thu, 20 Jun 2002, William John Burns wrote:

> All:
> None of the many online user posts in setting up Java connectivity from 
> within PHP have worked. RPM or tarball.
> Do you know of anyone who has an RPM of PHP, with the standard MySQL, 
> GD, Postgres, WDDX, etc...but also libphp_java.so correctly set-up?
> The Windows PHP has Java support right off the bat with an edit the the 
> .ini file. On Win 98, no problems at all. But on my Linux paritions...
> There are at least dozens of people trying to get this to work. All of 
> them could be helped with an RPM or a definitive answer. Why can't 
> someone release linux binaries with this sort of thing compiled in?
> My system: Sun Java2 JDK 1.4.0, Red Hat 7.1, Apache 1.3x. I have tried 
> all versions of PHP tarballs since 4.04p1 And I'm not alone in this 
> frustration.
> Yes, sometimes there is a libphp_java. There is always the .jar file. 
> But after editing the .ini, doing all manner of things with 
> LD_LIBRARY_PATH/ldconfig, nothing!
> The best I ever got was a page that registered the .so module, but never 
> finished output. (I use a test page with phpinfo(), then and a sample 
> call to get a Java timestamp. In this circumstance, the page cuts off 
> before the sample Java timestamp and instance.
> Any help or leads would be appreciated.
> Regards,
> WJ Burns

PHP General Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to